PHPGangsta - Der praktische PHP Blog

PHP Blog von PHPGangsta


mysql_* Funktionen noch im Code?

with 4 comments

Heute eine kleine Umfrage. Es ist anonym und keiner muss sich rechtfertigen (kann aber natürlich gern in den Kommentaren, die Gründe sind sicher interessant!).

Es geht um die ext/mysql Extension, sprich die mysql_* Funktionen. In PHP 5.5 wurden sie DEPRECATED, d.h. es gibt eine Deprecation-Warnung im PHP-Error-Log dass die Funktionen nicht mehr benutzt werden sollen da sie bald entfernt werden.

Nun stehen die Planungen für PHP 5.6 an, und eine Frage ist: Soll ext/mysql entfernt werden, nachdem es in der letzten Version als veraltet markiert wurde? Entfernen heißt in diesem Zusammenhang: Verschieben aus dem Kern in die PECL Library. Wer es unbedingt noch braucht kann es also separat nachinstallieren. Im englischen PHP-Online-Manual gibt es große rote Warnungen dass es nicht mehr genutzt werden sollte, in der deutschen Variante aber leider nicht.

Hier also meine kleine Umfrage:

Nutzt du noch ext/mysql?

View Results

Loading ... Loading ...

Ich selbst habe aktuell ein kleines Kommandozeilenscript das ich umschreiben muss, und WordPress nutzt es noch, ansonsten bin ich Dank dem Zend Framework, welches PDO nutzt, glaube ich ext/mysql-frei.

Written by Michael Kliewe

Januar 21st, 2014 at 1:37 pm

4 Responses to 'mysql_* Funktionen noch im Code?'

Subscribe to comments with RSS or TrackBack to 'mysql_* Funktionen noch im Code?'.

  1. Bin gespannt, wie schnell WordPress das umsetzen wird. Hoffe das geht schnell und schmerzlos.

    Markus F

    21 Jan 14 at 14:35

  2. Wenn man sich das Ticket dazu bei WordPress anguckt, wird einem Angst und Bange. Die Diskussionen drehen sich ständig im Kreis, es gibt zig Ansätze, aber keinen der sich durchsetzen will. Eigentlich sollte der Umstieg schon längst durch sein, wurde aber immer wieder verschoben. WordPress ist vom Coding her wirklich eine einzige Katastrophe. Aber wegen der riesigen Marktmacht kommt man nicht drumrum…

    https://core.trac.wordpress.org/ticket/21663

    as

    21 Jan 14 at 15:02

  3. Beim Voting fehlt noch “Ja, aber ich muss die nutzen, weil ich nicht auf PDO umstellen darf und ich schäme mich so dafür!”.
    Ansonsten hoffe ich auf ein besseres WordPress ;)

    Sascha Presnac

    21 Jan 14 at 19:10

  4. um gottes willen! ich frag mich schon seit 8 jahren wann der quatsch endlich raus fliegt. wenn’s in pecl landet, stellt sich die frage auch garnich mehr. wird zeit, dass fahrt aufgenommen wird. solch altlasten brauchen kein weiteres jahr herum geschleppt werden.

    glasz

    22 Jan 14 at 04:30

Leave a Reply

You can add images to your comment by clicking here.